You are using an unsupported browser. Please update your browser to the latest version on or before July 31, 2020.
close
You are viewing the article in preview mode. It is not live at the moment.
Home > General > How to Resolve Intel® Optane™ Memory Pinning Error: 'Unable to load DLL
How to Resolve Intel® Optane™ Memory Pinning Error: 'Unable to load DLL
print icon

Root cause
Starting with the 17.5.0.1017 Intel RST driver, the way the Intel® Optane™ memory pinning components are installed was modified. If at some point the driver was upgraded from an older driver (for example 16.8.x) to a version between 17.5.x and 17.8.x, the OS update may try to reapply the removed installation files from the earlier versions. Due to a compatibility issue, an error message may appear.

A system with factory installed (fresh OS installation) of Intel RST drivers between 17.5.x and 17.8.x are not affected by this issue.


How to fix it:

To resolve the issue and prevent it from occurring after a future OS update, please download and Install the Intel® Rapid Storage Technology (Intel® RST) driver version 17.9.1.1009 or greater here

If unable to update to the latest 17.9.1.1009 or greater driver, see below steps for an alternative solution:

First, refresh the current driver package installed by repairing the Intel® Optane™ memory pinning extensions:

  1. Open Programs and Features (Press Windows key  + r), type ‘appwiz.cpl’ and click OK.
  2. Locate and highlight Intel Optane Pinning Explorer Extensions.
  3. Click Repair.

 

 

Second, remove the old pinning package so that the error does not reappear after the next OS update:

  1. Open Device Manager (Press Windows key  + x).

  2. Expand the Software components field.
  3. Right-click the Intel® Pinning Shell Extensions field and select Uninstall Device.

  4. Check the box that states Delete the driver software for this device. and click Uninstall.

Feedback
0 out of 0 found this helpful

scroll to top icon